Back to overview
Degraded

Ongoing Email Provider Issue Impacting Open Links

Oct 10 at 12:34pm UTC
Affected services
Client Application

Resolved
Oct 10 at 01:47pm UTC

The email service is now up running again and all services are now available

Created
Oct 10 at 12:34pm UTC

We are currently experiencing an ongoing issue with our email provider, causing partial service disruption. This is affecting open links, and there might be delays in webhooks as well. Our team is actively investigating the issue and is dedicated to resolving it as soon as possible. We appreciate your patience and understanding during this time.